Aspire Core Experiencing Slowness

Incident Report for Aspire

Resolved

Aspire Core functionality has been restored. Please reach out to Aspire Care if you continue to experience issues.
Posted Jul 29, 2025 - 09:07 EDT

Update

We are continuing to investigate this issue.
Posted Jul 29, 2025 - 09:06 EDT

Investigating

We’re currently experiencing issues with slowness and unresponsiveness for some customers. Our team is actively investigating the issue and working to restore functionality as quickly as possible. We apologize for the inconvenience.
Posted Jul 29, 2025 - 08:40 EDT
This incident affected: Aspire Core.